Enable support for older CPU versions for VMware ESXi 7.x.

 

If you want to install a VMware ESXi on an older server, there is a change that the CPUs are not supported by VMware.

This article will describe how to overcome this without installing newer CPUs.

If you install ESXi 7.x you can get this error and warning message.

In this case hit F11 to reboot and wait for the server to reboot.

If ESXi is again loaded, there is a 5 seconds pause to enter additional boot parameters. In that case press Shift + O.

That is indicated as follows:

And append the following:

allowLegacyCPU=True

Like in the example below:

Hit Enter to continue, and after a while you get this warning.

Here you can now hit the Enter key again to continue.

If the server is booted, login as root and edit the following two boot.cfg files.

  • /bootbank/boot.cfg
  • /altbootbank/boot.cfg

Edit these files by appending the same setting to the kernelopt line parameter.

kernelopt=.... allowLegacyCPU=true